Categories
Security

Critical Chrome Update

Google has issued an emergency security update for all Chrome users as it confirms that attackers are already exploiting a high severity vulnerability – CVE-2022-1096
All Chrome users – over 3.2 billion – should make sure their browsers are updated as quickly as possible.
How to apply the Google Chrome security patch:Head for the Help|About option in your Google Chrome menu, and if the update is available, it will automatically start downloading.
Microsoft also confirmed that this vulnerability exists in Edge, which is a Chromium-based browser. Edge has also been updated to protect users against this exploit. Go to settings|about and if your browser version is 99.0.1150.55 or higher, it is no longer vulnerable to the CVE-2022-1096 issue. Chromium powers many other browsers, such as Brave and Vivaldi, so please check your browser is fully patched.
Still unsure if you’re as protected as you can be on line? Contact us – we can help!

Leave a Reply